通达信信号少

问:没有未来函数的通达信指标信号也会消失啊!!

信号消失很正常呀,当日的条件满足的时候条件成立,信号显现,但信号不满足的时候,信号自然会消失的。
对于取值月线或者周线的时候,当月的信号取决于当日信号,信号当然也自然会消失的。这不奇怪。只有到达月底 或者周末的时候仍能满足条件的情况下,信号才会被保留下来。文字的表达解释只能到这里了,还不理解我也就无能为力了。

问:通达信公式屏蔽信号问题

信号:= cross(C,MA5) AND MA5>MA10 AND C>=MA(C,10);
DRAWICON(信号,C*1.003,6);

问:求大神编一个通达信卖出信号指标,条件股价新高,当天成交量比昨天的少。

首先你要确定一个时间范围,多少日的新高.
下面公式参数n是时间范围.
例如日线参数n是10代表创10日新高.这只是个例子,例子中的参数没有任何意义,使用者需要自己根据自己的需求自行设置参数.
N:=10;
XG:H=HHV(H,N) AND V<REF(V,1);

问:这个通达信指标为什么不显示信号的呀?如何修改才可以显示啊?

按以下修改就显示了:
日K:="KD.K";
日D:="KD.D";
日J:="KDJ.J";
KD金花:COUNT(CROSS(日K,日D) AND CROSS(日J,日D),2)>=1;
{MACD买入条件}
XDIFF:="MACD.DIF";
XDEA:="MACD.DEA";
XMACD:="MACD.MACD";
MACD金花:COUNT(CROSS(XDIFF,XDEA) AND XDIFF>XDEA,2)>=1;
价金花:COUNT(CROSS(MA(C,5),MA(C,10)) OR CROSS(MA(C,10),MA(C,20)),2)>=1;
量金花:COUNT(CROSS(MA(VOL,5),MA(VOL,10)),2)>=1;
四朵金花:KD金花 AND MACD金花 AND 价金花 AND 量金花;

问:通达信选股公式 下面公式中出现 假突涨 信号写成选股公式,谢谢

B1:=MA(C,1);

B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);

SMA2:=MA(B2,3);{资金进出}

平均成交额:=SMA(AMOUNT,10,1)/10000000;

临界成交额:=MA(平均成交额,8);{加速跑道}

跑道AA:=MA(L,3);

跑道BB:=MA(L,26);

跑道AF:=CROSS(跑道AA,跑道BB);

跑道AF1:=CROSS(跑道BB,跑道AA);

上下穿数:=COUNT(跑道AF1,20)+COUNT(跑道AF,20);

CC:=EMA(上下穿数,10)*6;{资金额亿}

YUWEI:=MA(CLOSE,1)-MA(CLOSE,6);

线上:=YUWEI>0;

线上数:=COUNT(线上,15);

主力强度:=EMA(线上数,10);

MAVOL:=HHV(REF(VOL,1),3);

MDAY:=BARSLAST(MAVOL);

条件:=VOL>MAVOL AND CLOSE>REF(CLOSE,MDAY+1);

CC差:=ABS(CC-REF(CC,2));

DRAWTEXT(条件 AND CC>1 AND CC差<=1 AND COUNT(条件,2)<=1 AND 主力强度<=REF(主力强度,1),平均成交额*1.01,'!假突涨'),COLORRED;

问:请大大们做个通达信分时预警公式,如图出现黄色箭头为买入信号

H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8;
支撑:=L1+P1*0.5/8;
中:=(支撑+阻力)/2;
现价:=CLOSE;
XG:FILTER(CROSS(现价,支撑),230);